
Migrationsleitfaden von Linux Mail nach Groupwise

Einleitung
Um die E-Mail Landschaft am Campus der Universität Regensburg zu konsolidieren wurde 
als zentrales E-Mail-System Groupwise ausgewählt. Dieses System soll  Pegasus Mail und 
Linux Mail ablösen. Einer der Vorteile ist, dass eingehende Mails immer ankommen, auch 
wenn das Quota (Standard 750MB) überschritten ist. Im Groupwise System können die E-
Mails über mehrere Möglichkeiten abgerufen werden.

● WebAccess über Browser: https://gw.uni-regensburg.de/gw/webacc
● Groupwise – Client: Über Startmenü oder in der Konsole groupwise eingeben
● IMAP: Dazu gehören Programme wie Thunderbird / Icedove

ohne Support: Evolution, KMail, Pine / Alpine,...

Dokumentation:
http://www.uni-regensburg.de/e/r/Benutzer/Allgemein/Email/Groupwise/index_de.phtml

Umstellung / Groupwise-Antrag
Um  Groupwise  nutzen  zu  können,  müssen  Sie  einen  Groupwise-Account  beantragen. 
Danach wird die eingehende E-Mail nach Groupwise zugestellt, nicht mehr ins Linux-Home-
Verzeichnis.
https://webapp-nw.uni-regensburg.de/antrag/antrag_gw.phtml

Der Antrag wird von Hand bearbeitet,  benötigt  also eine gewisse Zeit.  Die Umstellung 
erfolgt in zwei Schritten: Erst wird der Groupwise-Account erstellt, dann wird die externe E-
Mail-Adresse  (vorname.nachname@fakultaet.uni-regensburg.de)  auf  den  Groupwise-
Account  umgeleitet.  Es  kann  also  vorkommen,  dass  Sie  -  obwohl  Groupwise  schon 
funktioniert - Ihre Mails noch kurzzeitig in Linux erhalten.

Zugriff auf die E-Mails in Groupwise
Hier sei vor allem auf die Dokumentation verwiesen:
http://www.uni-regensburg.de/e/r/Benutzer/Allgemein/Email/Groupwise/index_de.phtml

Es gibt folgende Möglichkeiten für den Zugriff:
● WebAccess über Browser: https://gw.uni-regensburg.de/gw/webacc
● Groupwise – Client: Über Startmenü oder in der Konsole groupwise eingeben

Dieser ist in ReX Lenny standardmäßig installiert.
● IMAP: Dazu gehören Programme wie Thunderbird / Icedove

ohne Support: Evolution, KMail, Pine / Alpine

Anmerkung:
Diese Dokumentation wurde unter ReX-Lenny getestet. (z.B. auf rex1 und rex2 installiert)
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Umstellung von Thunderbird / Icedove (ReX Lenny)
Ausgangspunkt  ist  eine  funktionierende  Thunderbird  /  Icedove  Konfiguration  für  Linux 
Mail. Zur Umstellung führen Sie folgende Schritte aus (nur ReX Lenny):

● Thunderbird / Icedove starten
● Edit → Account Settings
● Server Settings: Entfernen Sie den Haken bei:

„Check for new messages at startup“ und
„Check for new messages every .. minutes“

● Add Account...
● „Groupwise Universität Regensburg“ auswähen

→ Next
● Your Name:     Vorname Nachname 

Email Address: Vorname.Nachname@Fakultät.uni-regensburg.de
→ Next

● Incoming User Name: kurzer Login Name z.B. mib64002
→ Next   → Finish

● Groupwise   Account auswählen und 
Links unten im Fenster „Set as Default“ wählen

● OK (Account Settings)
● Thunderbird neu starten, Mails abrufen (Passwort eingeben)
● Edit → Account Settings
● Groupwise – Copies & Folders auswählen: 

„Place a copy in:“ → Other →  Groupwise → Sent Items 
● File → Subscribe → Groupwise Account wählen → Haken neben „Calendar“ wählen

Zum Schluss am besten Thunderbird / Icedove neu starten.

Umstellung von Evolution
Es  Sei  hier  betont,  dass  Evolution  nicht  vom  Rechenzentrum  unterstützt  wird.  Diese 
Anleitung dient nur als Hilfestellung, sie ist nicht ausgiebig getestet. Ausgangspunkt ist 
eine  funktionierende Evolution-Konfiguration  für  Linux  Mail.  Zur  Umstellung führen Sie 
folgende Schritte aus:

● → Bearbeiten → Einstellungen
● E-Mail-Konten wählen, → Hinzufügen (rechts) → Vor 
● Voller Name:

E-Mail-Adresse:
„Dieses zum Vorgabekonto machen“ anwählen 
→ Vor 

● Server-Art:        IMAP
Server:              imap.uni-regensburg.de
Benutzername: kurzer NDS Name z.B. mib64002
„Sichere Verbindung verwenden“: SSL-Verschlüsselung
→ Vor 

● „Automatisch nach neuen E-Mails sehen“
→ Vor 

● Server-Art: SMTP 
Server: mail.uni-regensburg.de
„Server fordert legitimation“ anwählen
Sichere Verbindung wählen: SSL-Verschlüsselung
Benutzername: kurzer NDS Name z.B. mib64002
→ Vor

● Konto – Name: beliebig, z.B. Groupwise – mib64002 
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→ Vor ; Zeitzone auswählen Europa/Berlin→ Anwenden
● Groupwise – Account anwählen 

→ Bearbeiten (rechts)
● → Vorgaben

„Ordner für verschickte Nachrichten“:  → Groupwise → „Sent Items“
● → Schließen

Umstellung von pine / alpine
Pine /Alpine wird nicht offiziell vom Rechenzentrum unterstützt! Diese Anleitung dient nur 
als Hilfestellung, sie ist nicht ausgiebig getestet. Starten Sie pine / alpine

Basis Konfiguration:
→  S (Setup) 
→  C (Config) und ändern Sie (ersetzten Sie dabei mib64002 mit ihrem Login Name):
Personal Name = Vorname Nachname
SMTP Server   = mail.uni-regensburg.de/novalidate-cert
Inbox Path      = {imap.uni-regensburg.de/user=mib64002/ssl/novalidate-cert}Inbox
Default Fcc     = {imap.uni-regensburg.de/user=mib64002/ssl/novalidate-cert}Sent Items 
Default Saved Message Folder      = {imap.uni-regensburg.de/user=mib64002/ssl/novalidate-
cert}Drafts
Postponed Folder  = {imap.uni-regensburg.de/user=mib64002/ssl/novalidate-cert}Drafts 
→ E (Exit) 
→ Y (commit changes) 

IMAP Ordner setzten:
→ S (Setup )
→ L (CollectionLists )
→ A (Create a new entry) ändern Sie:
Nickname  : Groupwise Folders 
Server        : imap.uni-regensburg.de/user=mib64002/ssl/novalidate-cert 
Path           : 
View          : 
→  ^X (Beenden) 
→  Groupwise Folders auswählen
→  $ (Shuffle) 
→  U (UP) (Damit Groupwise oberster Eintrag ist. Dies ist wichtig.)
→  E (Exit) 
Absendeadresse richtig setzen (notwendig):
→  S (Setup) 
→ R (Rules)
→ R (Rolle)
→ A (add ) und setzen Sie:
Nickname    = Uni-Regensburg 
(scroll down) 
Set From     =  Vorname Nachname <Vorname.Nachname@fakultät.uni-regensburg.de> 
Compose Use = (*)  Without confirmation 
Forward Use   = (*)  Without confirmation 
Reply   Use      = (*)  Without confirmation 
→ E (Exit Setup) 
→ Y (commit changes) 
→ E (Exit Setup) 
→ Y (commit changes) 
→ Q (Quit) 
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Andere Mail-Programme
Im Prinzip Kann jedes IMAP-fähige Mailprogramm auf Groupwise zugreifen. Dazu gehören 
Thunderbird  /  Icedove,  Evolution,  Pine/Alpine  KMail,  ...  .  Hier  sind  die  notwendigen 
Parameter um auf Groupwise zugreifen zu können nochmals zusammengefasst:

Imap-Server:         imap.uni-regensburg.de
Verschlüsselung:   SSL (Port 993)
Benutzername:     kurzer NDS z.B. mib64002 
Ausgangsordner für Mails: „Sent Items“ (empfohlen, nicht zwingend)

Ausgangsoptionen:
SMTP-Server:         mail.uni-regensburg.de
Verschlüsselung:    SSL (Port  465)
Benutzername:      kurzer NDS z.B. mib64002 

Anmerkungen zu Imap mit Groupwise:
Termine:

Groupwise kann Termine richtig verwalten, dazu besitzt Groupwise-Client eine Kalender-
Ansicht.  Ankommende  Termine,  das  sind  Emails  mit  einem  Termin-Anhang,  werden 
automatisch  in  den  Terminkalender  eingetragen.  Bei  Zugriff  über  das  Imap-Protokoll 
erscheinen diese Termine im Ordner „Calendar“, und nicht in der Inbox. Stellen Sie bitte 
im Imap-Client sicher, in diesem Ordner nach neuen Emails gesucht wird!  

Thunderbird:  File → Subscribe → Groupwise Account wählen 
→ Haken neben „Calendar“ wählen

Wenn eine Terminbenachrichtigung in der Inbox benötigt wird, gibt es auch folgende 
Möglichkeit:
    Groupwise-Client starten:  Werkzeuge → Regeln → Neu 
    Ereignis: Neue Nachricht -> Empfangen
    Bedingung: Kategorie: Termin, Job, Notiz
    Aktion hinzufügen: Weiterleiten: An sich selbst

Sent Items (Ausgangsnachrichten):

Dies ist ein spezieller Ordner. Wenn Emails dort hin verschoben werden, sind sie nicht mehr 
sichtbar.  Mit  der  Suchoption  im  Grupwise-Client  können  sie  jedoch  wieder  gefunden 
werden.  Deswegen  mit  einem  Imap-Client  keine  Emails  in  den  Ordner  Sent-Items 
verschieben.
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Importieren der E-Mails ins Groupwise System
Überlegen Sie zuerst ob Sie wirklich alle Mails ins Groupwise System importieren wollen, 
und ob wirklich alle Mails benötigt werden. Dies wäre ein guter Zeitpunk die Mails zu 
sortieren. Zum Importieren dient das Programm  rexMigrateEmail  das auf Rechnern mit 
ReX Lenny standardmäßig installiert ist (z.B. rex2). Dises Tool syncronisiert die E-Mails von 
Linux nach Groupwise, auf der Linux Seite wird nichts gelöscht. (Das Programm kann auch 
abgebrochen werden und später neu gestartet werden.)

Öffnen Sie eine Konsole und geben rexMigrateEmail ein: 
rex2:~> rexMigrateEmail 
This tool copies your Emails from your 
Linux Mailbox to the Groupwise Mailbox 
for the user mib64002. 
Do you want to proceed? [y/n] y 
Continuing. 

­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­ 
Only proceed if you have already an Groupwise Account! 
...
Your Linux Mailbox seems to use (including Spam and Trash): 8 MB 
­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­ 
Have you read the obove notice? [y/n] y 
Continuing. 

Creating logfile for Email syncronisation: rexMigrateEmail_rig09789.log.HZLZU 

What's the password for mib64002@rrzlic2.uni­regensburg.de? 
   Success login on [rrzlic2.uni­regensburg.de] with user[mib64002] auth [LOGIN] 
   Success login on [imap.uni­regensburg.de] with user [mib64002] auth [LOGIN] 
   ++++ Calculating sizes ++++ 
   ++++ Calculating sizes ++++ 
   ++++ Listing folders ++++ 
   ++++ Looping on each folder ++++ 
   ++++ From [INBOX] Parse 1 ++++ 
   ++++ To   [LinuxMail/INBOX] Parse 1 ++++ 
   ++++ Verifying [INBOX] ­> [LinuxMail/INBOX] ++++...... 
   ++++ End looping on each folder ++++ 
   ++++ Statistics ++++ 

   ++++ Statistics ++++ 
   Time                   : 10 sec 
   Messages transferred   : 27 
   Messages skipped       : 0 
   Total bytes transferred: 117457 
   Total bytes skipped    : 0 
   Total bytes error      : 0 
   Detected 0 errors 

Logfile is written to :rexMigrateEmail_rig09789.log.HZLZU 
Finished. 
rex2:~>

Jetzt erscheinen die kopierten E-Mails in Groupwise unter dem Ordner LinuxMail. Falls sie 
mit  Thunderbird  auf  die  Mails  zugreifen,  müssen  sie  zu  diesem  Ordner  ein  Subscribe 
ausführen, damit sie sichtbar sind:
File → Subscribe... →  Account: entsprechenden Account auswählen 
→ Hacken bei LinuxMail → Ok.

Anmerkungen:
Beim Kopieren der Mails wird ab ca. 400 MB das Groupwise Quota überschritten. Sind im 
Linux Mail Verzeichnis mehr als 400 MB vorhanden wird der Kopiervorgang nicht gestartet. 
Besprechen Sie sich in diesem Fall mit ihrem Workgroupmanager. Das Kopieren kann mit 
der Option -f (rexMigrateEmail ­f) trotzdem gestartet werden.
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Importieren des Adressbuchs  in Groupwise von Icedove / 
Thunderbird 
In das Groupwise-System können auch Kontakte importiert werden. Dies ist sinnvoll, wenn 
Sie bereits gepflegte Kontaktadressen (in Thunderbird) besitzen und den Groupwise Client, 
oder den Web-Access benutzen wollen.

● Downlod der Thunderbird Extention MoreFunctionsForAddressBook von:
● http://nic-nac-project.de/~kaosmos/morecols-en.html   

ganz unten auf der Seite :
Download  MoreFunctionsForAddressBook - 0.5.5.3 version (TB 1.0 - 2.0)

● Thunderbird / Icedove starten
→ Tools →  Add-Ons → Install
Die Datei morefunctionsforAB-0.5.5.3.xpi  auswählen
→ Öffnen → Install Now → Restart Icedove

● → Tools → Addressbook 
● Tools → Zusätzliche Einstellungen → vCard-Format

→ „UTF-8 (v.2.1)“ auswählen → Ok
● Alle Kontakte markieren, die exportiert werden sollen
● Im Adressbuch → Tools → Kontakte → „Als VCard exportieren“
● Ordner auswählen → Speichern
● Neu angelegten Ordner auf einen Windows Rechner mit installiertem Groupwise 

Client kopieren
● Groupwise Client unter Windows starten
● → Werkzeuge → Adressbuch 
● Im Adressbuch → Datei → Importieren
● Order mit Vcards Kontakten suchen und alle Kontakte markieren → Öffnen
● Adressbuch auswählen (Eigenes Buch, nicht Primärbuch) → Ok

Anmerkungen:
Der  Linux Groupwise Client  (8.0.1)  kann keine Adressbücher  importieren,  der  Windows 
Client kann Adressbücher u.a. im Format Vcard (Version 2.1) importieren (Bei Vcard 3.0 
werden nicht alle Felder richtig übernommen, z.B. Telefon; dagegen werden Namen und E-
Mail richtig übernommen. ) 

Stand: 14. Oktober 2009
Michael Hartung

Versionsstand:
Groupwise Client Linux: 8.0.1 (ReX-Lenny)
Groupwise Client Windows: 8.0.1
Thunderbird/Icedove: 2.0.0.22 (ReX-Lenny)
pine/alpine: 1.10 (ReX-Lenny)
Evolution: 2.22.3.1 (ReX-Lenny)
Thunderbird Plugin morefunctionsforAB: 0.5.5.3
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